60226: Acronis Cyber Backup: backup fails with "The shadow copy provider had an unexpected error"

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Last update: Tue, 2020-07-14 14:21

Symptoms

A backup operation fails with this error message:

| error 0x10c442: Failed to start creating the volume snapshot.
| line: 0x3fec04e376b8a1c5
| file: k:\3539\fdisk\win_snapshot.cpp:1231
| function: win_snapshot_core::CallSbLock
| $module: arx_agent_fork_vsa64_3539
|
| error 0x9: The shadow copy provider had an unexpected error while trying to process the specified operation.
| line: 0x2aacb7b2ab852ac
| file: k:\3539\fdisk\ver2\arch\windows\win_errors.cpp:40
| function: Fdisk::AddKstatusError
| code: 0x8004230f
| $module: arx_agent_fork_vsa64_3539

OR

The backup has failed because '<VSS provider>' has failed during the snapshot creation.

2. You have a 3rd party backup solution - StorageCraft ShadowProtect - installed on the machine along with Acronis software.

3. You check the snapapi logs of the backup operation and find the following text:

[20170328-031651-806][SnapAPI][T] Installed VSS providers:
[20170328-031651-890][SnapAPI][T]   {24602736-BED9-4619-91B0-243447C6409C} type 2 [StorageCraft Volume Snapshot Software Provider]
[20170328-031651-890][SnapAPI][T]   {89300202-3CEC-4981-9171-19F59559E0F2} type 4 [Microsoft File Share Shadow Copy provider]
[20170328-031651-890][SnapAPI][T]   {B5946137-7B9F-4925-AF80-51ABD60B20D5} type 1 [Microsoft Software Shadow Copy provider 1.0]

[20170328-031652-077][SnapAPI][T] VSS providers for volume \\?\Volume{3edffc71-ab8d-11e6-93e7-806e6f6e6963}\:
[20170328-031652-078][SnapAPI][T]   {24602736-BED9-4619-91B0-243447C6409C} type 2 [StorageCraft Volume Snapshot Software Provider]
[20170328-031652-078][SnapAPI][T]   {B5946137-7B9F-4925-AF80-51ABD60B20D5} type 1 [Microsoft Software Shadow Copy provider 1.0]

Cause

When Acronis Cyber Backup attempts to create a snapshot, it calls for an incorrect VSS provider (StorageCraft Volume Snapshot Software Provider) and eventually process fails. 

This issue can also occur due to Hyper-V IC Software Shadow Copy Provider (with appropriate messages in logs).

Solution

In backup plan settings, select the Use Microsoft Software Shadow Copy provider option.

  1. In backup plan, click the gear icon to open settings.
  2. Under Volume Shadow Copy Service (VSS), select Use Microsoft Software Shadow Copy provider:

 

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