63198: Acronis Cyber Protect Cloud: Agent installation fails on registration step with "Error 0x26a001a: Random bytes generation failed"

use Google Translate

Last update: Fri, 2020-05-01 06:16

Symptoms

You are installing Acronis Agent for Windows. Installation fails on the registration step with:
The confirmation is timed out. Check if the device is online, connected to the network, and the agent setup program displays the registration window. If this is the case, and the device has not appeared under 'devices', repeat the registration.

In Windows event logs you see this error:
Event ID 36874: An unknown connection request was received from a remote client application, but none of the cipher suites supported by the client application are supported by the server. The SSL connection request has failed.

In upgrade tool logs (C:\ProgramData\Acronis\UpgradeTool\upgrade-<date>T<time>Z-<pid>\) you see this error:
Error 0x26a001a: Random bytes generation failed. Details: 'error:24064064:lib(36):func(100):reason(100)'
| line: 0x380c7f78bc4b8fa8
| file: e:\354\enterprise\common\security\core\impl\crypto_rand.cpp:41
| function: Scrambler::RandBytes
| $module: security_core_vsa64_12960

Cause

LanmanWorkstation service is stopped.

During product registration, installed Acronis Agent communicates with the management server in Acronis Cloud. To secure this communication Acronis software uses OpenSSL toolkit v.1.0.2 for generating encryption keys. This version of OpenSSL depends on LanmanWorkstation service to generate a random sequence as a secret.

Solution

In future versions we will upgrade the OpenSSL toolkit to version 1.1.0, where the implementation of generating random numbers has been changed.

As workaround, start LanmanWorkstation service (simplified name "Workstation" for display) on the affected machine:

  1. Press Win+R and type services.msc. Click OK to open Services window
  2. Right-click Workstation service and select Properties. Select the Startup typeAutomatic and click OK. Right-click Workstation service and select Restart.

Retry the installation.