63212: Acronis Cyber Protect Cloud: MMS service cannot be started, error "error 0x30002: CannotBind"

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Last update: Wed, 2020-10-14 20:53

Symptoms

You want to register a machine with Acronis Agent in the management server. Registration fails. You check Acronis Managed Machine service and notice that it is stopped.

When you try to start the service, you get this error (logged in Windows event logs):
Error 0xb9000b: Failed to initialize network module.
| trace level: error
| line: 0xb957662f70a242f
| file: e:\327\enterprise\service\impl\server.cpp:678
| function: Core::ServerImpl::StartNetworkServer
| $module: mms_vsa64_12420
|
| error 0x30002: CannotBind
| line: 0xe6f03fbb500414fa
| file: e:\327\enterprise\common\async_ipc\async\io_base_libevent.cpp:371
| function: AsyncIpc::Libevent::IoBase::Activate
| $module: asyncipc_vsa64_12420

Cause

Port 9850 required by Acronis Agent is used by another software.

Solution

Check which software uses port 9850.

In Windows:

  1. Run:
    netstat -ant | findstr 9850
    to find the PID of the process listening on 9850
  2. Run:
    tasklist /fi "pid eq <PID>
    where <PID> is the process ID found in step 1.

In Linux:

  1. Run:
    netstat -tanp | grep 9850
    to find the PID of the process listening on 9850
  2. Run:
    ps -p <PID> -o comm=
    where <PID> is the process ID found in step 1.

In the current product design, it is impossible to change this port for Acronis Agent. Please change the settings of the 3rd party application to use another port.

Acronis development team is working on an option to configure this port in Acronis software.