65653: Acronis Cyber Protect Cloud: Mailbox backup or recovery fails with "Failed to connect to Microsoft Exchange API using url '{0}'"

use Google Translate

Last update: 31-05-2021

Symptoms

Backup and/or recovery of an Exchange mailbox fails with the message similar to the following:

Cannot open public folder or mailbox <user@domain.com>

Access is denied.

Failed to connect to Microsoft Exchange API using url '{0}'

uri: https://%my_public_domain_address%/EWS/Exchange.asmx

Where %my_public_domain_address% is your public mail server address.

Cause

Incorrect Exchange configuration, where internal URL points to your public mail server address.

To work around this misconfiguration please use the solution below.

Solution

As a workaround, you can force a correct EWS Uri in Acronis Registry settings.

1. Check whether this is a standalone server or a cluster to find what URI you need.

  1. If it's a standalone server, use FQDN of your Exchange server,

    e.g. https://myserver.domain.local/EWS/Exchange.asmx

    where myserver.domain.local is FQDN of your Exchange server.

  2. If it's a Cluster, use FQDN of your Exchange node with CAS role.

    e.g. https://myexch02.domain.local/EWS/Exchange.asmx

    where myexch02.domain.local is FQDN of your Exchange node with CAS role.

2. Configure URI to access EWS on current server:

  1. Open Windows Registry Editor (regedit) on the Exchange machine and go to HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\ArxAgent\Settings\ 
  2. Create a new String value with the name EwsUri and set the following as the value from step 1.

    DO NOT put url that you found in Internal-Url from output of Get-WebServicesVirtualDirectory

  3. Reattempt the recovery

Tags: