67492: Acronis Cyber Protect Cloud: Agent registration fails with "failed to register agent: failed to validate possible tenant change: no access to tenant"

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Last update: 31-05-2021

Symptoms

You are registering an Acronis Agent and get this error:

| error 0x247000c: {"domain":"AGENT_CORE","code":"DEPENDENCY_ERROR","context":{"response":{"json":{"domain":"AGENT_MANAGER","code":"ACCESS_DENIED","debug":{"msg":"POST (886e29285a8d608f8b554c24c6a0f448) to /api/agent_manager/v2/agent_registrations for agent (fb1409ce-aca5-5c2b-9fc7-bebec1277b77): failed to register agent: failed to validate possible tenant change: no access to tenant '535652'"}}}},"debug":{"msg":"ensure registration: register with agent manager: POST https://eu4-cloud.acronis.com:443/api/agent_manager/v2/agent_registrations, status '403': AGENT_MANAGER.ACCESS_DENIED: POST (876e29385a8d608f8b554c24c6a0f448) to /api/agent_manager/v2/agent_registrations for agent (fb1409ce-aca5-5c2b-9fc7-bebec1277b77): failed to register agent: failed to validate possible tenant change: no access to tenant '1999'"}}
| line: 0x5b89cde5313bd154

Cause

This device is already registered under a different tenant.

This part of the error shows the old tenant where this device is sitting:

failed to register agent: failed to validate possible tenant change: no access to tenant '1999'

Solution

Remove the device from the old tenant and retry registration to the new tenant.

Device can be unregistered by using register_agent tool on the Agent machine with the following command:

register_agent.exe -o unregister 

If you don't know right away which tenant this Agent might be registered to, check the tenant ID using APIv1:

  1. Log in to the Management Portal.
  2. Change the URL to https://<your data center>.acronis.com/api/1/group/<ID from the error message>
    For example, the error message above occurs on a tenant 1999 in EU4 data center. The API request should be:
    https://eu4-cloud.acronis.com/api/1/groups/1999
  3. Search for name: