事象
「処理がタイム アウトしました。」というエラーが表示され、バックアップまたは他の操作に失敗します。
原因
タイムアウトのためディスク システムの起動に失敗する場合、このエラーが発生します。例えば、起動時間の長い USB ドライブ、SD カードや他のストレージが接続されているときに発生することが多いです。
バックアップのデータを書き込む前に、エージェントはすべてのストレージ デバイスを含むディスクシステムを起動する必要があります。デバイスの一部が15分以内に起動されていない場合は、このエラーが表示されます。
ソリューション #1
このコンピュータに USB ドライブまたは SD カードが接続されている場合、これらのストレージデバイスのドライバをアップデートしてください。ドライバが古いと、起動時間が長くてこのエラーにつながる可能性があります。また、バックアップ計画のソースまたはターゲットになっていない USB ドライブおよび SD カードは、コンピュータから取り外してください。
また、USB ドライブのアンマウント時に問題が発生した場合、オペレーティングシステムはそのドライブをまだ接続されているように認識していて、このエラーを表示させる場合もあります。ディスクが正常にコンピュータから取り外されたことを確認するために、以下の手順に従ってください:
- [ディスクの管理] を開きます(Win+R を押し、diskmgmt.msc と入力し、[OK] をクリックします)。そこで、実際には取り外されたが、接続されているように表示されているディスクがないかチェックします。
- Acronis システムレポート を収集します。出力として、診断情報を含むアーカイブが生成されます。その中でディスク レポートを見つけて、開いて、何らかの USB ディスクが検出されているかチェックします。以下の例をご参照ください:
コンピュータに接続されている USB ドライブまたは SD カードがない場合は、このエラーの原因としては、特定のディスクの応答時間が長すぎることも考えられます。ディスクの製造者によるディスク チェック ユーティリティを実行し、ディスクの健康状態をチェックしてください。
ソリューション #2
もう一つのソリューションは、service_process.exe のタイムアウト時間を延長することです。そのデフォルトの値は15分(エージェント for Windows ビルド 12210 以降)または5分(エージェント for Windows ビルド 12210 より前のバージョン、エージェント for Linux および Mac)になっています。この問題が発生する場合は、デフォルトのタイムアウト時間を30分にすることを推奨します。
- Acronis エージェントがインストールされている Windows コンピュータで、[スタート] -> [ファイル名を指定して実行] に移動し、regedit.exe と入力し、Enter キーを押します。
- このキーに移動します:
HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\BackupAndRecovery\CommonComponents\ServiceProcess\Settings\ - 新しいDWORD(32ビット)値を登録します。DWORDの名前は StartTimeout で、DWORDの値は例えば 1800000 にしておきましょう。表記は10 進数に設定します。
(!) DWORD名で大文字と小文字が区別されるので、文字の大きさに注意してください。名は、正に、StartTimeoutです。
(!) DWORD値の単位は、ミリ秒です。例えば、30分は 1800000(30*60*1000=1800000)になります。
- このキーに移動します:
- Linux システムの場合は、/etc/Acronis/BackupAndRecovery.config.を開きます。
- 以下の行を探します:
<key name="ServiceProcess">
<key name="Settings> - 「Settings」セクションに以下の値を追加します:
<value name="StartTimeout" type="Tdword">
"300000"
</value>
- 以下の行を探します:
(!) デフォルトのタイムアウト時間を延長すると、バックアップの作成時間も長くなります。デフォルトのタイムアウトを延長したくない場合は、ソリューション #1 を使うことを推奨します。
ソリューション #1 とソリューション #2 を実行しても、問題が解決しなかった場合、このデバイスからシステム情報を収集し、Acronis サポートへお問い合わせください。